<!DOCTYPE html> <!--[if lt IE 7]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]--> <!--[if IE 7]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8"> <![endif]--> <!--[if IE 8]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js"> <!--<![endif]--><head><meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no" /><meta charset="UTF-8"><link rel="pingback" href="https://utdmercury.com/xmlrpc.php" /> <script type="application/ld+json">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</script> <title>From Cricket to Comet - THE MERCURY</title><style type="text/css">@font-face{font-family:'socialfans';src:url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/socialfans.eot?v=4.4.1);src:url('https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/socialfans.eot?v=4.4.1#iefix') format('embedded-opentype'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/socialfans.woff?v=4.4.1) format('woff'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/socialfans.ttf?v=4.4.1) format('truetype'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/socialfans.svg?v=4.4.1) format('svg');font-weight:400;font-style:normal}</style><style type="text/css">@font-face{font-family:'fontawesome';src:url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/fontawesome.eot?v=4.4.1);src:url('https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/fontawesome.eot?v=4.4.1#iefix') format('embedded-opentype'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/fontawesome.woff?v=4.4.1) format('woff'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/fontawesome.woff2?v=4.4.1) format('woff2'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/fontawesome.ttf?v=4.4.1) format('truetype'),url(https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/font/fontawesome.svg?v=4.4.1) format('svg');font-weight:400;font-style:normal}</style> <script>window._wca = window._wca || [];</script> <link rel="canonical" href="https://utdmercury.com/from-cricket-to-comet/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="From Cricket to Comet - THE MERCURY" /><meta property="og:description" content="Former player for Singapore&#8217;s national cricket team continues to play leisurely at UTD Computer science freshman Karthik Mohan is just like any other student, except for one major difference. At the age of 14, he represented Singapore as a cricket player on the national stage.&nbsp; Advertisement Mohan played for the..." /><meta property="og:url" content="https://utdmercury.com/from-cricket-to-comet/" /><meta property="og:site_name" content="THE MERCURY" /><meta property="article:section" content="Life &amp; Arts" /><meta property="article:published_time" content="2020-02-24T03:45:55-06:00" /><meta property="article:modified_time" content="2020-02-24T03:45:57-06:00" /><meta property="og:updated_time" content="2020-02-24T03:45:57-06:00" /><meta property="og:image" content="https://utdmercury.com/wp-content/uploads/2020/02/MG_8792-1024x683.jpg" /><meta property="og:image:secure_url" content="https://utdmercury.com/wp-content/uploads/2020/02/MG_8792-1024x683.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="683" /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//secure.gravatar.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="THE MERCURY &raquo; Feed" href="https://utdmercury.com/feed/" /><link rel="alternate" type="application/rss+xml" title="THE MERCURY &raquo; Comments Feed" href="https://utdmercury.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="THE MERCURY &raquo; From Cricket to Comet Comments Feed" href="https://utdmercury.com/from-cricket-to-comet/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.10.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-40560198-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-40560198-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/utdmercury.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='vcv:assets:front:style-css'  href='https://utdmercury.com/wp-content/plugins/visualcomposer/public/dist/front.bundle.css?ver=23.0' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://utdmercury.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='wc-block-style-css'  href='https://utdmercury.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css?ver=2.4.5' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css'  href='https://utdmercury.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='bp-nouveau-css'  href='https://utdmercury.com/wp-content/plugins/buddypress/bp-templates/bp-nouveau/css/buddypress.min.css?ver=5.1.1' type='text/css' media='screen' /><link rel='stylesheet' id='contact-form-7-css'  href='https://utdmercury.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' /><link rel='stylesheet' id='flytedesk-digital-css'  href='https://utdmercury.com/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' /><link rel='stylesheet' id='wpos-slick-style-css'  href='https://utdmercury.com/wp-content/plugins/recent-post-slider-with-widget/rpsw-assets/css/slick.css?ver=1.1' type='text/css' media='all' /><link rel='stylesheet' id='rpsw-public-style-css'  href='https://utdmercury.com/wp-content/plugins/recent-post-slider-with-widget/rpsw-assets/css/recent-post-style.css?ver=1.1' type='text/css' media='all' /><link rel='stylesheet' id='wpoh-font-awesome-css'  href='https://utdmercury.com/wp-content/plugins/recent-post-slider-with-widget/rpsw-assets/css/font-awesome.min.css?ver=1.1' type='text/css' media='all' /><link rel='stylesheet' id='rs-plugin-settings-css'  href='https://utdmercury.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.8.2' type='text/css' media='all' /><style id='rs-plugin-settings-inline-css' type='text/css'></style><link rel='stylesheet' id='socialfans-widget-style-css'  href='https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/css/socialfans-style.css?ver=4.4.1' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-widget-style-css'  href='https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/css/font-awesome.min.css?ver=4.4.1' type='text/css' media='all' /><link rel='stylesheet' id='team_manager-normalize-css-css'  href='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/css/normalize.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='team_manager-awesome-css-css'  href='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/css/font-awesome.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='team_manager-featherlight-css-css'  href='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/css/featherlight.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='team_manager-magnific-css-css'  href='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/css/magnific-popup.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='team_manager-animate-css-css'  href='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/css/animate.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='team_manager-style1-css-css'  href='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/css/style1.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='woocommerce-layout-css'  href='https://utdmercury.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=3.8.1' type='text/css' media='all' /><style id='woocommerce-layout-inline-css' type='text/css'>.infinite-scroll .woocommerce-pagination{display:none}</style><link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://utdmercury.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=3.8.1' type='text/css' media='only screen and (max-width: 768px)' /><link rel='stylesheet' id='woocommerce-general-css'  href='https://utdmercury.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=3.8.1' type='text/css' media='all' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required{visibility:visible}</style><link rel='stylesheet' id='wordpresscom-stats-smiley-remover-css'  href='https://utdmercury.com/wp-content/plugins/wordpresscom-stats-smiley-remover/css/wordpresscom-stats-smiley-remover.css?ver=15.01' type='text/css' media='all' /><link rel='stylesheet' id='wppsac-public-style-css'  href='https://utdmercury.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/css/recent-post-style.css?ver=2.2.4' type='text/css' media='all' /><link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://utdmercury.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.0.1' type='text/css' media='all' /><link rel='stylesheet' id='magellan-bootstrap-css'  href='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/css/bootstrap.min.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='magellan-vendor-css'  href='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/css/vendor.css?ver=5.3.2' type='text/css' media='all' /><link rel='stylesheet' id='magellan-main-less-css'  href='https://utdmercury.com/wp-content/uploads/wp-less-cache/magellan-main-less.css?ver=1582134225' type='text/css' media='all' /><link rel='stylesheet' id='magellan-style-css'  href='https://utdmercury.com/wp-content/themes/planetshine-magellan-child/style.css?ver=5.3.2' type='text/css' media='all' /><style id='magellan-style-inline-css' type='text/css'>body{background-image:none}body{background-repeat:repeat!important}body{background-attachment:fixed!important}</style><link rel='stylesheet' id='magellan-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A400%2C700%2C900&#038;subset=latin%2Clatin-ext' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='https://utdmercury.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.2' type='text/css' media='all' /><link rel='stylesheet' id='themewich-shortcodes-css'  href='https://utdmercury.com/wp-content/plugins/themewich-shortcodes/css/themewich-shortcodes.css?ver=5.3.2' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/utdmercury.com","hash_tracking":"false"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.0'></script> <script type='text/javascript'>/* <![CDATA[ */ var impression_object = {"ajax_url":"https:\/\/utdmercury.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var click_object = {"ajax_url":"https:\/\/utdmercury.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/buddypress/bp-core/js/widget-members.min.js?ver=5.1.1'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/buddypress/bp-core/js/jquery-query.min.js?ver=5.1.1'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-cookie.min.js?ver=5.1.1'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-scroll-to.min.js?ver=5.1.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var flytedesk_digital_publisher = {"uuid":"0476c284-d334-407c-816f-98e3f8e1ce55"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.8.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.8.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/js/wow.js?ver=1.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/js/modernizr.custom.js?ver=1.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/js/classie.js?ver=1.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/js/featherlight.js?ver=1.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/js/jquery.magnific-popup.js?ver=1.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/team-showcase-pro/assets/js/main.js?ver=1.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/themewich-shortcodes/js/modernizr.min.js?ver=2.8.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script> <script type='text/javascript'>/* <![CDATA[ */ var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/utdmercury.com","is_cart":"","cart_redirect_after_add":"no"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=3.8.1'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/js_composer/assets/js/vendors/woocommerce-add-to-cart.js?ver=5.7'></script> <script type='text/javascript'>/* <![CDATA[ */ var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/utdmercury.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"14610","token":"ce135f9ddb","debug":""}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.0.1'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/modernizr.min.js?ver=5.3.2'></script> <link rel='https://api.w.org/' href='https://utdmercury.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://utdmercury.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://utdmercury.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><meta name="generator" content="WooCommerce 3.8.1" /><link rel='shortlink' href='https://wp.me/p4uNy4-3NE' /><link rel="alternate" type="application/json+oembed" href="https://utdmercury.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Futdmercury.com%2Ffrom-cricket-to-comet%2F" /><link rel="alternate" type="text/xml+oembed" href="https://utdmercury.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Futdmercury.com%2Ffrom-cricket-to-comet%2F&#038;format=xml" /><style type="text/css" media="screen">.g{margin:0;padding:0;overflow:hidden;line-height:1;zoom:1}.g img{height:auto}.g-col{position:relative;float:left}.g-col:first-child{margin-left:0}.g-col:last-child{margin-right:0}.g-1{margin:1px 1px 1px 1px;width:100%;max-width:336px;height:100%;max-height:280px}.g-2{width:100%;max-width:728px;height:100%;max-height:90px;margin:0 auto}.g-5{width:auto;height:100%;max-height:200px;margin:0 auto}.g-6{margin:0 0 0 0;width:100%;max-width:300px;height:100%;max-height:400px}.g-8{margin:0 0 0 0;width:100%;max-width:300px;height:100%;max-height:400px}@media only screen and (max-width:480px){.g-col,.g-dyn,.g-single{width:100%;margin-left:0;margin-right:0}}</style> <script type="text/javascript">var ajaxurl = 'https://utdmercury.com/wp-admin/admin-ajax.php';</script> <meta name="generator" content="Powered by Visual Composer Website Builder - fast and easy to use drag and drop builder for experts and beginners."/><script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type="text/javascript">/* <![CDATA[ */ jQuery.post("https://utdmercury.com/wp-admin/admin-ajax.php", { action: "wmp_update", id: 14610, token: "11b7f0efb9" }); /* ]]> */</script><link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><meta name="generator" content="Planetshine - Magellan - 1.0.0"> <noscript><style>.woocommerce-product-gallery{opacity:1!important}</style></noscript><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://utdmercury.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--> <script type="text/javascript">jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 6000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 6000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 6000 });
	jQuery('.g-6').gslider({ groupid: 6, speed: 6000 });
	jQuery('.g-8').gslider({ groupid: 8, speed: 6000 });
}
});</script> <meta name="generator" content="Powered by Slider Revolution 5.4.8.2 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." /><link rel="icon" href="https://i2.wp.com/utdmercury.com/wp-content/uploads/2017/04/mercfaviconUPDATED.png?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i2.wp.com/utdmercury.com/wp-content/uploads/2017/04/mercfaviconUPDATED.png?fit=48%2C48&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/utdmercury.com/wp-content/uploads/2017/04/mercfaviconUPDATED.png?fit=48%2C48&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i2.wp.com/utdmercury.com/wp-content/uploads/2017/04/mercfaviconUPDATED.png?fit=48%2C48&#038;ssl=1" /> <script type="text/javascript">function setREVStartSize(e){									
						try{ e.c=jQuery(e.c);var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;
							if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
						}catch(d){console.log("Failure at Presize of Slider:"+d)}						
					};</script> <style type="text/css" id="wp-custom-css">.container-flud.footer{margin:auto}</style><noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript><script async src='https://stats.wp.com/s-202009.js'></script> </head><body data-rsssl=1 class="bp-nouveau post-template-default single single-post postid-14610 single-format-standard theme-planetshine-magellan unknown planetshine magellan child desktop-device vcwb woocommerce-no-js full-width-bg trending-slider-fixed wpb-js-composer js-comp-ver-5.7 vc_responsive no-js"><div class="lightbox lightbox-login"> <a href="#" class="btn btn-default btn-dark close"><i class="fa fa-times"></i></a><div class="container"><div class="row"><form class="magellan-login" name="loginform" id="loginform" action="https://utdmercury.com/wp-login.php" method="post"><p class="input-wrapper"> <input name="log" id="user_login" type="text" placeholder="Username" /></p><p class="input-wrapper"> <input type="password" name="pwd" id="user_pass" placeholder="Password" /></p><p class="input-wrapper"> <input type="submit" name="wp-submit" id="wp-submit" value="Login" /></p><p class="input-wrapper"> <input type="checkbox" name="rememberme" value="forever" id="rememberme"><label>Remember me</label> <a href="https://utdmercury.com/wp-login.php?action=lostpassword" class="lost-password">Lost your password?</a></p></form></div></div></div><div class="lightbox lightbox-search"> <a href="#" class="btn btn-default btn-dark close"><i class="fa fa-times"></i></a><div class="container"><div class="row"><form method="get" action="https://utdmercury.com/" class="search-form"><p class="search-wrapper"><input type="text" placeholder="Search here" class="search-input-lightbox" name="s"><input type="submit" value="Search" class="btn-search-lightbox"></p></form><div class="row lightbox-items"><div id="widget_contact_info-7" class="col-md-4 col-xs-12 widget-default widget-footer widget_contact_info"><div class="title-default"><span>Location</span></div><div itemscope itemtype="http://schema.org/LocalBusiness"><div class="confit-address" itemscope itemtype="http://schema.org/PostalAddress" itemprop="address"><a href="https://maps.google.com/maps?z=16&#038;q=800+w+campbell+rd,+richardson,+tx+75080" target="_blank">800 W Campbell Rd, <br/>Richardson, TX 75080</a></div><div class="confit-phone"><span itemprop="telephone">972-883-2286</span></div><div class="confit-hours" itemprop="openingHours">Student Union 1.601 <br/>Monday - Friday 9 AM - 4 PM</div></div></div><div id="custom_html-11" class="widget_text col-md-4 col-xs-12 widget-default widget-footer widget_custom_html"><div class="title-default"><span>Mailing List</span></div><div class="textwidget custom-html-widget"><a class="button" href="http://eepurl.com/did5An">Subscribe</a></div></div><div id="text-10" class="col-md-4 col-xs-12 widget-default widget-footer widget_text"><div class="title-default"><span>Interested?</span></div><div class="textwidget"><p>Email us at editor@utdmercury.com with your name, major, year and area of interest.</p></div></div><div id="adswidget1-quick-adsense-reloaded-8" class="col-md-4 col-xs-12 widget-default widget-footer quads-ad1_widget"><div id="quads-ad1_widget" style="float:none;margin:0px;">  <script async data-cfasync="false" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" data-cfasync="false">var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px;" data-ad-client="pub-9946473207256140" data-ad-slot="2404064778" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px;" data-ad-client="pub-9946473207256140" data-ad-slot="2404064778" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px;" data-ad-client="pub-9946473207256140" data-ad-slot="2404064778" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px;" data-ad-client="pub-9946473207256140" data-ad-slot="2404064778" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div></div></div></div></div></div><div class="container-fluid trending-slider"><div id="trending-slider" class="carousel slide" data-ride="carousel" data-interval="false"><div class="controls right"> <a href="#" class="close-trending-slider"><i class="fa fa-times"></i></a><div><p>Trending Articles</p><div class="buttons"> <a href="#trending-slider" data-slide="prev" class="btn btn-default"><i class="fa fa-caret-left"></i></a> <a href="#trending-slider" data-slide="next" class="btn btn-default"><i class="fa fa-caret-right"></i></a></div></div></div><div class="carousel-inner"><div class="slide item  active"><div class="post-block post-video post-trending"><div class="row"><div class="post"><div class="title"><h3><a href="https://utdmercury.com/game-review-legends-of-runeterra/"><span>Game  Review: ‘Legends of Runeterra’</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/game-review-legends-of-runeterra/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LoR_graphic.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LoR_graphic.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/from-cricket-to-comet/"><span>From Cricket to Comet</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/from-cricket-to-comet/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/what-is-literature-research-like/"><span>What is Literature Research Like?</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/what-is-literature-research-like/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9301-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9301-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/"><span>Putting Pen to Paper: Note-taking Habits</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/IMG_7059-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/IMG_7059-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/"><span>Exhibit Honors Holocaust Liberators</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9451-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9451-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div></div></div></div><div class="slide item "><div class="post-block post-video post-trending"><div class="row"><div class="post"><div class="title"><h3><a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/"><span>Professor Offers Free Pantry in Office to Combat Food Insecurity</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9260-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9260-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/the-pregnant-scholar/"><span>The Pregnant Scholar</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/the-pregnant-scholar/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/PregnancyOnCampus.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/PregnancyOnCampus.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/mens-tennis-starts-season-anew/"><span>Men&#8217;s Tennis Starts Season Anew</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/mens-tennis-starts-season-anew/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i1.wp.com/utdmercury.com/wp-content/uploads/2020/02/menstennis.png?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i1.wp.com/utdmercury.com/wp-content/uploads/2020/02/menstennis.png?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/for-your-ignorance-ep-3-2-10-20/"><span>For Your Ignorance Ep. 3 &#8211; 2/10/20</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/for-your-ignorance-ep-3-2-10-20/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i1.wp.com/utdmercury.com/wp-content/uploads/2020/01/FYI.png?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i1.wp.com/utdmercury.com/wp-content/uploads/2020/01/FYI.png?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/letter-to-the-editor-on-campus-housing-is-purpose-built/"><span>Letter to the Editor: On-Campus Housing is Purpose-built</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/letter-to-the-editor-on-campus-housing-is-purpose-built/" class="link"></a></div></div></div></div></div></div></div><div class="slide item "><div class="post-block post-video post-trending"><div class="row"><div class="post"><div class="title"><h3><a href="https://utdmercury.com/over-what-weight-debunking-the-body-mass-index/"><span>Over What Weight?  Debunking the Body Mass Index</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/over-what-weight-debunking-the-body-mass-index/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/mental-health.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/mental-health.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/food-for-late-night-thoughts/"><span>Food for Late-night Thoughts</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/food-for-late-night-thoughts/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/FOOD.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/FOOD.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/socialism-critiqued/"><span>Socialism: Critiqued</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/socialism-critiqued/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LOCKED-ON-TRUTH-FINAL.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LOCKED-ON-TRUTH-FINAL.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/socialism-supported/"><span>Socialism: Supported</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/socialism-supported/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/final-common-sense.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/final-common-sense.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="post"><div class="title"><h3><a href="https://utdmercury.com/utd-takes-part-in-national-recycling-challenge/"><span>UTD Takes Part in National Recycling Challenge</span></a></h3></div><div class="overlay-wrapper  image-fx"><div class="content"><div> <a href="https://utdmercury.com/utd-takes-part-in-national-recycling-challenge/" class="link"></a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8886-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div><div class="image  image-fx" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8886-scaled.jpg?resize=389%2C389&#038;ssl=1);"></div></div></div></div></div></div></div></div><div class="focus"><div class="container-fluid dock"><div class="container"><div class="trending-posts"><div class="tags"><div class="trending"><a href="#">Trending</a></div></div><div id="trending-posts" class="carousel slide" data-ride="carousel" data-interval="false"><div class="controls"> <a href="#trending-posts" data-slide="next"><i class="fa fa-caret-left"></i></a> <a href="#trending-posts" data-slide="prev"><i class="fa fa-caret-right"></i></a></div><div class="carousel-inner"><div class="item active"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/game-review-legends-of-runeterra/">Game  Review: ‘Legends of Runeterra’</a></h3><div class="legend"> <a href="https://utdmercury.com/game-review-legends-of-runeterra/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/game-review-legends-of-runeterra/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/from-cricket-to-comet/">From Cricket to Comet</a></h3><div class="legend"> <a href="https://utdmercury.com/from-cricket-to-comet/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/from-cricket-to-comet/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/what-is-literature-research-like/">What is Literature Research Like?</a></h3><div class="legend"> <a href="https://utdmercury.com/what-is-literature-research-like/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/what-is-literature-research-like/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/">Putting Pen to Paper: Note-taking Habits</a></h3><div class="legend"> <a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/">Exhibit Honors Holocaust Liberators</a></h3><div class="legend"> <a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/">Professor Offers Free Pantry in Office to Combat Food Insecurity</a></h3><div class="legend"> <a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/the-pregnant-scholar/">The Pregnant Scholar</a></h3><div class="legend"> <a href="https://utdmercury.com/the-pregnant-scholar/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/the-pregnant-scholar/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/mens-tennis-starts-season-anew/">Men&#8217;s Tennis Starts Season Anew</a></h3><div class="legend"> <a href="https://utdmercury.com/mens-tennis-starts-season-anew/" class="time">February 17, 2020</a> <a href="https://utdmercury.com/mens-tennis-starts-season-anew/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/for-your-ignorance-ep-3-2-10-20/">For Your Ignorance Ep. 3 &#8211; 2/10/20</a></h3><div class="legend"> <a href="https://utdmercury.com/for-your-ignorance-ep-3-2-10-20/" class="time">February 10, 2020</a> <a href="https://utdmercury.com/for-your-ignorance-ep-3-2-10-20/#respond" class="comments">0</a></div></div></div></div><div class="item"><div class="post-item"><div class="title"><h3><a href="https://utdmercury.com/letter-to-the-editor-on-campus-housing-is-purpose-built/">Letter to the Editor: On-Campus Housing is Purpose-built</a></h3><div class="legend"> <a href="https://utdmercury.com/letter-to-the-editor-on-campus-housing-is-purpose-built/" class="time">February 9, 2020</a> <a href="https://utdmercury.com/letter-to-the-editor-on-campus-housing-is-purpose-built/#respond" class="comments">0</a></div></div></div></div></div></div></div><div class="social-login"><div class="social"> <a href="https://www.facebook.com/TheUTDMercury/" target="_blank"><i class="fa fa-facebook-square"></i></a> <a href="https://twitter.com/utdmercury?lang=en" target="_blank"><i class="fa fa-twitter-square"></i></a> <a href="https://www.youtube.com/channel/UCgF6kGFcR6HR_c2O5cL2JfQ/featured" target="_blank"><i class="fa fa-youtube-square"></i></a> <a href="https://www.instagram.com/utdmercury/" target="_blank"><i class="fa fa-instagram"></i></a></div><div class="login"> <a href="#" class="show-lightbox">Account</a></div></div></div></div><div class="container header header-items-1"><div class="logo-1 header_item single_centered" style="max-width: 800px;"> <a href="https://utdmercury.com/"><img src="https://i1.wp.com/utdmercury.com/wp-content/uploads/2019/12/The-Mercury-1.png?fit=942%2C200&#038;ssl=1" alt=""></a></div></div><div class="container mega-menu-wrapper"><div class="mega-menu"> <a class="togglemenu" href="#">Main menu</a><div class="container"><div class="default-menu"><ul id="menu-primary" class="nav"><div class="logo-2"><a href="https://utdmercury.com/">THE MERCURY</a></div><li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://utdmercury.com/"><i class="fa fa-home"></i><span class="home-text-title">Homepage</span></a></li><li id="menu-item-9" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9 dropdown"><a title="News" href="https://utdmercury.com/category/news/" data-toggle="dropdown" data-hover="dropdown" class="dropdown-toggle disabled" aria-haspopup="true"><span>News</span></a><ul role="menu"><li id="menu-item-10558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10558"><a title="Photo Galleries" href="https://utdmercury.com/category/photo-gallery/"><span>Photo Galleries</span></a></li><li id="menu-item-9183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9183"><a title="Podcast Episodes" href="https://utdmercury.com/category/news/podcasts/"><span>Podcast Episodes</span></a></li><li id="menu-item-9184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9184"><a title="Audio Packages" href="https://utdmercury.com/category/news/audio/"><span>Audio Packages</span></a></li></ul></li><li id="menu-item-8" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8"><a title="Life &amp; Arts" href="https://utdmercury.com/category/life-arts/"><span>Life &#038; Arts</span></a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a title="Opinion" href="https://utdmercury.com/category/opinion/"><span>Opinion</span></a></li><li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a title="Sports" href="https://utdmercury.com/category/sports/"><span>Sports</span></a></li><li id="menu-item-1028" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1028"><a title="Newspaper" href="https://utdmercury.com/eeditions-2/"><span>Newspaper</span></a></li><li id="menu-item-7453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7453"><a title="Advertise" href="https://utdmercury.com/advertising/"><span>Advertise</span></a></li><li id="menu-item-7452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-7452 dropdown"><a title="Contact Us" href="https://utdmercury.com/contact-us/" data-toggle="dropdown" data-hover="dropdown" class="dropdown-toggle disabled" aria-haspopup="true"><span>Contact Us</span></a><ul role="menu"><li id="menu-item-12464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12464"><a title="Join" href="https://utdmercury.com/join/"><span>Join</span></a></li><li id="menu-item-7471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7471"><a title="Source FAQs" href="https://utdmercury.com/source-faqs/"><span>Source FAQs</span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page search-launcher"><a href="#"><i class="fa fa-search"></i></a></li></ul></div></div></div></div><div class="container main-content-wrapper post-main-wrapper sidebar-disabled"><div class="main-content hentry post-14610 post type-post status-publish format-standard has-post-thumbnail category-life-arts"><div class="row"><div class="col-md-12 post-block post-page-title-small"><img width="2560" height="1707" src="https://utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=600%2C400&amp;ssl=1 600w, https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?w=1360&amp;ssl=1 1360w" sizes="(max-width: 2560px) 100vw, 2560px" /><div class="featured_caption" style="font-style: italic;">Computer science freshman Karthik Mohan played as an all-rounder in the Singaporean national cricket team. Photo by Roshan Khichi | Mercury Staff</div></div></div><div class="row"><div class="col-md-12 post-block "><div class="post-title"><div class="tags"><div><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts" class="tag-default">Life &amp; Arts</a></div></div></div><h3><a href="https://utdmercury.com/from-cricket-to-comet/">From Cricket to Comet</a></h3><div class="postcontent content"><div class=""><h5>Ruhma Khan</h5><a>Mercury Staff</a></div></div><div class="legend"> <a href="https://utdmercury.com/2020/02/23/" class="time">February 23, 2020</a> <a href="https://utdmercury.com/from-cricket-to-comet/#respond" class="comments">0</a></div></div><div class="post-controls" id="postid-14610" data-nonce="3bbc05cd60"><div> <share-button class="share-button" data-button-text="Share" data-url="https://utdmercury.com/from-cricket-to-comet/" data-title="From Cricket to Comet" data-description="Former player for Singapore&#8217;s national cricket team continues to play leisurely at UTD Computer science freshman Karthik Mohan is just like any other student, except for one major difference. At the age of 14, he represented Singapore as a cricket player on the national stage.&nbsp; Advertisement Mohan played for..." data-image="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?fit=2560%2C1707&#038;ssl=1"></share-button></div></div><div class="the-content-container"><p><em>Former player for Singapore&#8217;s national cricket team continues to play leisurely at UTD</em></p><p>Computer science freshman Karthik Mohan is just like any
other student, except for one major difference. At the age of 14, he
represented Singapore as a cricket player on the national stage.&nbsp;</p><div class="g g-5"><div class="g-dyn a-80 c-1"><style>.mercury-divider{border:0;height:0;border-top:1px solid rgba(0,0,0,.1);border-bottom:1px solid rgba(255,255,255,.3)}</style><div class="mercury-inline-ad"><hr style="margin-top:5px;" class="mercury-divider"><div><p style="color:darkgray;margin-bottom:6px;">Advertisement</p><a class="gofollow" data-track="ODAsNSwxLDYw" href="https://mpi.swoogo.com/wti-funny-socialism-tour-2020"><img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/WTI_728x90_Dallas.jpg?ssl=1" /></a></div><hr style="margin-top:20px;" class="mercury-divider"></div></div></div><p>Mohan played for the team’s under-19 division and said he
was introduced to the game while on vacation in India.</p><p>“I was born in India, and everyone there usually plays
cricket in their free time, and how I picked it up was my uncle introduced me
to the game (when I was) around 4 years old,” Mohan said.</p><div class="g g-6"><div class="g-dyn a-80 c-1"><style>.mercury-divider{border:0;height:0;border-top:1px solid rgba(0,0,0,.1);border-bottom:1px solid rgba(255,255,255,.3)}</style><div class="mercury-inline-ad"><hr style="margin-top:5px;" class="mercury-divider"><div><p style="color:darkgray;margin-bottom:6px;">Advertisement</p><a class="gofollow" data-track="ODAsNiwxLDYw" href="https://mpi.swoogo.com/wti-funny-socialism-tour-2020"><img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/WTI_728x90_Dallas.jpg?ssl=1" /></a></div><hr style="margin-top:20px;" class="mercury-divider"></div></div></div><p>Mohan said he would usually play with his cousins and began
to play more competitively when he returned to Singapore and played for his
school’s team.</p><p>“When I was 13 or 14 years old, one of my high school
coaches was an ex-National League player,” Mohan said. “He recommended that I
should try out for the trials. I went for the trials and then from there, they
just picked me.”&nbsp;</p><p>Mohan said his family and friends were encouraging of his
decision to pursue cricket and that their support made it easier to balance his
academics and the sport.</p><div class="g g-7"><div class="g-single a-80"><style>.mercury-divider{border:0;height:0;border-top:1px solid rgba(0,0,0,.1);border-bottom:1px solid rgba(255,255,255,.3)}</style><div><hr style="margin-top:5px;" class="mercury-divider"><div><p style="color:darkgray;margin-bottom:6px;">Advertisement</p><a class="gofollow" data-track="ODAsNywxLDYw" href="https://mpi.swoogo.com/wti-funny-socialism-tour-2020"><img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/WTI_728x90_Dallas.jpg?ssl=1" /></a></div><hr style="margin-top:20px;" class="mercury-divider"></div></div></div><p>“My family was a bit hesitant because they were wondering
how I was going to be able to cope, my studies and cricket together,” he said.
“Then as time went by, I was able to get a good balance of everything. Without
the help of my family and friends it would have been hard.”</p><p>Mohan, who played as an all-rounder in the national team,
also played for his school, Raffles Institution. Mohan said the transition from
playing on a school team to playing on the national team was overwhelming due
to the pressures and expectations placed on players.</p><p>“Usually when you play in school teams, the expectations of
you are not really that high,” he said. “They just want you to give your best,
but when it comes to the national team you have to perform because it&#8217;s for
your country, so the level of competition is really hard.”</p><p>He continued to play for his school’s cricket team while
training for the national team and said that it was challenging to balance
training with academics and leisure time.</p><p>“I used to train every day. Then, because of my training &#8230;
I didn&#8217;t have time to study. My academics took a hit,” Mohan said. “Once you&#8217;re
involved in something for so long, you tend to sacrifice other stuff such as
family time and going out with friends. You have to sacrifice; you have to
learn how to manage your time properly.”</p><p>Having friends from his school who also played on the
national team and were going through the same experience made the transition
easier, Mohan said.</p><p>“It was a lot of people going through the same thing, having
the same experience of having the pressure to play for the national team and
the school team and perform well in both and study at the same time,” Mohan
said. “It was certainly hard for us, but the fact that we all knew that we had
each other&#8217;s backs was something that helped us fight through the hard times.”</p><p>Playing cricket on the national level, Mohan said, forced
him and his teammates to constantly push themselves to exceed expectations.</p><p>“When people realize that you&#8217;re in the national team, they
set a certain level of expectations for you. Knowing that those expectations
existed motivated us to make sure we were always fulfilling or exceeding those
expectations,” he said. “It was a challenge but it was certainly something fun
that I enjoyed doing because I learned a lot from those experiences.”</p><p>Players for the national team came from schools around
Singapore, including schools that Mohan had played against at the high schol
level. Mohan said the experience of becoming teammates with his rivals and
learning to play together was one of his favorite memories of playing for the
national team.</p><p>&nbsp;“When you’re younger,
you see your opponents as someone you don’t like. But then, as you spend more time
(together), then you realize everyone is going through the same thing as you
and everyone wants to win,” he said. “Everyone is on the same team as you. So
you put aside those differences and you come together as a team, which is a
really enriching experience.”</p><p>The decision to stop playing for the national team was
difficult, Mohan said, but he had known that he had always wanted to study
overseas and that it would be difficult to pursue both at the same time.</p><p>&nbsp;“My coaches knew that
I had the potential to be a really good player. But I (made) the decision
considering the future. It was a difficult decision to make, but I do not
regret the decision,” he said. “Cricket is more of a passion in the sense that
it’s something I always did in my free time, I couldn&#8217;t really consider it as a
future.””</p><p>Playing cricket at the national level, Mohan said, has given
him a good work ethic and self-discipline that has transferred over into other
aspects of his life.</p><p>“I wasn&#8217;t the fastest person, I wasn&#8217;t the strongest person
or I wasn&#8217;t the fittest person. But I always made sure I worked the hardest in
the team,” he said. “That helped me set an example, not just in cricket, but in
the sense that when it comes to studies I was trying to do the same thing.”</p><p>Mohan said he continues to play cricket as a student at UTD,
joining a team of students who play every weekend. He said his advice to others
who wish to play for their national team is to work hard and that it is not
impossible.</p><p>“When you play for your country, (it) requires a lot of
sacrifice and patience. It’s really hard to manage everything. The thing is,
people might think it&#8217;s not possible,” Mohan said. “But if you have the passion
for the game and the willingness and the pride for your country, anyone can
play for their national team in the sport they&#8217;re interested in. If you’re
willing to put in the work you can definitely make it.”</p></div></div></div><div class="row"><div class="col-md-12 post-block post-image-60 next-previous-wrapper"><div class="next-previous"><div class="previous"> <span class="tag">Previous</span><div class="post"><div class="overlay-wrapper text-overlay" data-click-url="https://utdmercury.com/exhibit-honors-holocaust-liberators/"><div class="content"><div><div class="tags"><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts">Life &amp; Arts</a></div></div><a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9451-scaled.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image"> <a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/"><img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9451-scaled.jpg?resize=60%2C60&#038;ssl=1" alt="Exhibit Honors Holocaust Liberators"></a></div><div class="title"><h3><a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/">Exhibit Honors Holocaust Liberators</a></h3></div></div></div><div class="next"> <span class="tag">Next</span><div class="post"><div class="overlay-wrapper text-overlay" data-click-url="https://utdmercury.com/game-review-legends-of-runeterra/"><div class="content"><div><div class="tags"><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts">Life &amp; Arts</a></div></div><a href="https://utdmercury.com/game-review-legends-of-runeterra/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LoR_graphic.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image"> <a href="https://utdmercury.com/game-review-legends-of-runeterra/"><img src="https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LoR_graphic.jpg?resize=60%2C60&#038;ssl=1" alt="Game  Review: ‘Legends of Runeterra’"></a></div><div class="title"><h3><a href="https://utdmercury.com/game-review-legends-of-runeterra/">Game  Review: ‘Legends of Runeterra’</a></h3></div></div></div></div></div></div><div class="row"><div class="col-md-12 comments comments-wrapper"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/from-cricket-to-comet/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://utdmercury.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><div class="row"><div class="col-md-4 col-sm-12"><p class="input-wrapper"><label>Name <b>*</b></label><input id="author" name="author" type="text" value="" aria-required='true' /></p></div><div class="col-md-4 col-sm-12"><p class="input-wrapper"><label>E-mail <b>*</b></label><input id="email" name="email" type="text" value="" aria-required='true' /></p></div><div class="col-md-4 col-sm-12"><p class="input-wrapper"><label>Website</label><input id="url" name="url" type="text" value=""/></p></div></div><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><div class="row"><div class="col-md-12"><p class="input-wrapper"><textarea id="comment" name="comment" aria-required="true"></textarea></p></div></div><p class="form-submit"><div class="row"><div class="col-md-12"><p class="input-wrapper"><input type="submit" value="Post comment"><span class="notes">Your email address will not be published. Required fields are marked <b>*</b></span></p></div></div> <input type='hidden' name='comment_post_ID' value='14610' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f965330e2c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="92"/></p></form></div></div></div></div></div><div class="container-flud footer"><div class="container"><div class="row"><div id="nav_menu-3" class="col-md-4 col-xs-12 widget-default widget-footer widget_nav_menu"><div class="menu-topbar-container"><ul id="menu-topbar" class="menu"><li id="menu-item-6186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6186"><a href="https://utdmercury.com/contact-us/">Contact Us</a></li><li id="menu-item-6187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6187"><a href="https://utdmercury.com/advertising/">Advertising</a></li></ul></div></div><div id="custom_html-3" class="widget_text col-md-4 col-xs-12 widget-default widget-footer widget_custom_html"><div class="title-default"><span>Mailing List</span></div><div class="textwidget custom-html-widget"><a class="button" href="http://eepurl.com/did5An">Subscribe</a></div></div><div id="magellan_sidebar_post_tabs-3" class="col-md-4 col-xs-12 widget-default widget-footer magellan_sidebar_post_tabs"><div class="post-block post-image-60 slider switchable-tabs"><div class="sorting"><div class="buttons"> <a href="#" class="btn btn-sort active">Recent</a> <a href="#" class="btn btn-sort">Comments</a></div></div><div class="row"><div class="col-xs-12"><div class="switcher-tab-content"><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts" class="tag-default">Life &amp; Arts</a></div></div></div> <a href="https://utdmercury.com/game-review-legends-of-runeterra/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LoR_graphic.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/game-review-legends-of-runeterra/"> <img src="https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/LoR_graphic.jpg?resize=60%2C60&#038;ssl=1" alt="Game  Review: ‘Legends of Runeterra’"> </a></div><div class="title"><h3><a href="https://utdmercury.com/game-review-legends-of-runeterra/">Game  Review: ‘Legends of Runeterra’ </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts" class="tag-default">Life &amp; Arts</a></div></div></div> <a href="https://utdmercury.com/from-cricket-to-comet/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/from-cricket-to-comet/"> <img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_8792-scaled.jpg?resize=60%2C60&#038;ssl=1" alt="From Cricket to Comet"> </a></div><div class="title"><h3><a href="https://utdmercury.com/from-cricket-to-comet/">From Cricket to Comet </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/news/" title="News" class="tag-default">News</a></div></div></div> <a href="https://utdmercury.com/what-is-literature-research-like/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9301-scaled.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/what-is-literature-research-like/"> <img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9301-scaled.jpg?resize=60%2C60&#038;ssl=1" alt="What is Literature Research Like?"> </a></div><div class="title"><h3><a href="https://utdmercury.com/what-is-literature-research-like/">What is Literature Research Like? </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/news/" title="News" class="tag-default">News</a></div></div></div> <a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/IMG_7059-scaled.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/"> <img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/IMG_7059-scaled.jpg?resize=60%2C60&#038;ssl=1" alt="Putting Pen to Paper: Note-taking Habits"> </a></div><div class="title"><h3><a href="https://utdmercury.com/putting-pen-to-paper-note-taking-habits/">Putting Pen to Paper: Note-taking Habits </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts" class="tag-default">Life &amp; Arts</a></div></div></div> <a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9451-scaled.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/"> <img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9451-scaled.jpg?resize=60%2C60&#038;ssl=1" alt="Exhibit Honors Holocaust Liberators"> </a></div><div class="title"><h3><a href="https://utdmercury.com/exhibit-honors-holocaust-liberators/">Exhibit Honors Holocaust Liberators </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts" class="tag-default">Life &amp; Arts</a></div></div></div> <a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9260-scaled.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/"> <img src="https://i0.wp.com/utdmercury.com/wp-content/uploads/2020/02/MG_9260-scaled.jpg?resize=60%2C60&#038;ssl=1" alt="Professor Offers Free Pantry in Office to Combat Food Insecurity"> </a></div><div class="title"><h3><a href="https://utdmercury.com/professor-offers-free-pantry-in-office-to-combat-food-insecurity/">Professor Offers Free Pantry in Office to Combat Food Insecurity </a></h3></div></div></div></div></div><div class="switcher-tab-content"><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/life-arts/" title="Life &amp; Arts" class="tag-default">Life &amp; Arts</a></div></div></div> <a href="https://utdmercury.com/new-club-engineers-equality/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2017/01/unnamed-1.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/new-club-engineers-equality/"> <img src="https://i0.wp.com/utdmercury.com/wp-content/uploads/2017/01/unnamed-1.jpg?resize=60%2C60&#038;ssl=1" alt="New club engineers equality"> </a></div><div class="title"><h3><a href="https://utdmercury.com/new-club-engineers-equality/">New club engineers equality </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/news/" title="News" class="tag-default">News</a></div></div></div> <a href="https://utdmercury.com/sg-senators-vote-adopt-resolution-condemn-bathroom-bill/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i1.wp.com/utdmercury.com/wp-content/uploads/2017/01/Bathroom-Bill.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/sg-senators-vote-adopt-resolution-condemn-bathroom-bill/"> <img src="https://i1.wp.com/utdmercury.com/wp-content/uploads/2017/01/Bathroom-Bill.jpg?resize=60%2C60&#038;ssl=1" alt="SG senators vote to adopt resolution to condemn &#8216;bathroom bill&#8217;"> </a></div><div class="title"><h3><a href="https://utdmercury.com/sg-senators-vote-adopt-resolution-condemn-bathroom-bill/">SG senators vote to adopt resolution to condemn &#8216;bathroom bill&#8217; </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/opinion/" title="Opinion" class="tag-default">Opinion</a></div></div></div> <a href="https://utdmercury.com/alt-right-movement-ill-defined-use/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2017/01/17_0_06_AltRight_v02.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/alt-right-movement-ill-defined-use/"> <img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2017/01/17_0_06_AltRight_v02.jpg?resize=60%2C60&#038;ssl=1" alt="‘Alt-right’ movement too ill-defined for use"> </a></div><div class="title"><h3><a href="https://utdmercury.com/alt-right-movement-ill-defined-use/">‘Alt-right’ movement too ill-defined for use </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/opinion/" title="Opinion" class="tag-default">Opinion</a></div></div></div> <a href="https://utdmercury.com/endorse-hillary-clinton-presidency/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2016/11/Black-and-white.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/endorse-hillary-clinton-presidency/"> <img src="https://i0.wp.com/utdmercury.com/wp-content/uploads/2016/11/Black-and-white.jpg?resize=60%2C60&#038;ssl=1" alt="Editorial Board: We endorse Hillary Clinton for presidency"> </a></div><div class="title"><h3><a href="https://utdmercury.com/endorse-hillary-clinton-presidency/">Editorial Board: We endorse Hillary Clinton for presidency </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/opinion/" title="Opinion" class="tag-default">Opinion</a></div></div></div> <a href="https://utdmercury.com/anti-trump-protesters-safeguard-first-amendment-right/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i0.wp.com/utdmercury.com/wp-content/uploads/2016/12/op.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/anti-trump-protesters-safeguard-first-amendment-right/"> <img src="https://i0.wp.com/utdmercury.com/wp-content/uploads/2016/12/op.jpg?resize=60%2C60&#038;ssl=1" alt="Anti-Trump protesters safeguard First Amendment right"> </a></div><div class="title"><h3><a href="https://utdmercury.com/anti-trump-protesters-safeguard-first-amendment-right/">Anti-Trump protesters safeguard First Amendment right </a></h3></div></div></div></div><div class="row "><div class="col-xs-12"><div class="post"><div class="overlay-wrapper text-overlay  image-fx"><div class="content"><div><div class="tags"><div><div><a href="https://utdmercury.com/category/news/" title="News" class="tag-default">News</a></div></div></div> <a href="https://utdmercury.com/alum-starts-local-branch-international-charity/" class="btn btn-default btn-dark">Read more</a></div></div><div class="overlay" style="background-image: url(https://i2.wp.com/utdmercury.com/wp-content/uploads/2016/12/DSC_2525.jpg?resize=60%2C60&#038;ssl=1);"></div></div><div class="image  image-fx"> <a href="https://utdmercury.com/alum-starts-local-branch-international-charity/"> <img src="https://i2.wp.com/utdmercury.com/wp-content/uploads/2016/12/DSC_2525.jpg?resize=60%2C60&#038;ssl=1" alt="Alum starts local branch of international charity"> </a></div><div class="title"><h3><a href="https://utdmercury.com/alum-starts-local-branch-international-charity/">Alum starts local branch of international charity </a></h3></div></div></div></div></div></div></div></div></div></div><div class="row"><div class="col-md-12 copyright"></div></div></div></div><a href="#" class="back-to-top"><i class="fa fa-caret-up"></i></a></div> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });</script> <div style="display:none"></div> <script type="text/javascript">var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/visualcomposer/public/dist/front.bundle.js?ver=23.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script> <script type='text/javascript'>/* <![CDATA[ */ var BP_Nouveau = {"ajaxurl":"https:\/\/utdmercury.com\/wp-admin\/admin-ajax.php","confirm":"Are you sure?","show_x_comments":"Show all %d comments","unsaved_changes":"Your profile has unsaved changes. If you leave the page, the changes will be lost.","object_nav_parent":"#buddypress","objects":{"0":"activity","1":"members","4":"xprofile","7":"settings","8":"notifications"},"nonces":{"activity":"615921e962","members":"a09bc9ef1f","xprofile":"9eadc1a9f2","settings":"ddd384eefc","notifications":"66965db9fe"}}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/buddypress/bp-templates/bp-nouveau/js/buddypress-nouveau.min.js?ver=5.1.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/utdmercury.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202009'></script> <script type='text/javascript'>/* <![CDATA[ */ var SfcounterObject = {"ajaxurl":"https:\/\/utdmercury.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/socialfans-counter/assets/js/socialfans-script.js?ver=4.4.1'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/droppable.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/themewich-shortcodes/js/jquery.magnific-popup.min.js?ver=0.9.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/js_composer/assets/lib/bower/isotope/dist/isotope.pkgd.min.js?ver=5.7'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/themewich-shortcodes/js/themewich.shortcodes.js?ver=1.4.1'></script> <script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script> <script type='text/javascript'>/* <![CDATA[ */ var WPGroHo = {"my_hash":""}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/bootstrap.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/jquery.ui.touch-punch.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/jquery.inview.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/jquery.cycle2.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/jquery.mobile.custom.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/share-button.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/jquery.particleground.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/vendor/jquery.nicescroll.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/planetshine-mega-menu.js?ver=5.3.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var magellan_js_params = {"ajaxurl":"https:\/\/utdmercury.com\/wp-admin\/admin-ajax.php","enable_sidebar_affix":"on","particle_color":"#eaeaea"}; /* ]]> */</script> <script type='text/javascript' src='https://utdmercury.com/wp-content/themes/planetshine-magellan/theme/assets/js/theme.js?ver=5.3.2'></script> <script type='text/javascript' src='https://utdmercury.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script> <script async="async" type='text/javascript' src='https://utdmercury.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script> <script type='text/javascript' src='https://stats.wp.com/e-202009.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.2',blog:'66445652',post:'14610',tz:'-6',srv:'utdmercury.com'} ]);
	_stq.push([ 'clickTrackerInit', '66445652', '14610' ]);</script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1582516006 -->